GEM Desktop Select Multiple Icons (Drag)

You should see icons in the bottom window representing the items on
the disk in drive A. If the icons didn’t appear, try double-clicking more
rapidly.

(You can adjust the speed with which you must double-click using the
Set preferences command described on page 9-9)

SELECT MULTIPLE ICONS (DRAG)

Sometimes you’ll want to select more than one icon at a time. For
example, you might want to select several icons so you can copy
them all in one operation.

“Drag” means press and hold down the mouse button while you move
the mouse. When you drag, you form a “rubber rectangle” that
expands and contracts as you move the pointer. When the rubber
rectangle touches the icons you want to select (it doesn’t have to
completely surround them), release the mouse button. GEM Desktop
highlights the icons you select with the rubber rectangle.

You can only form the rubber-rectangle by dragging from upper left to
lower right.

Important Note: To form the rubber rectangle, you must begin the
drag operation with the pointer in an open area of the window. If you
start with the pointer directly on an icon, you'll drag that icon. This is
another use for dragging we'll describe later in this section.

Study the following illustration and then try dragging on your Desktop
to select multiple icons:
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Select Multiple Icons (Shift—click) GEM Desktop
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release mouse button. v

To de-select all of the icons you just selected, click in an open area of
either window.

SELECT MULTIPLE ICONS (SHIFT-CLICK)

When you use the drag technique to select icons on the Desktop, you
can only select icons that are next to each other. You can use the
“Shift-click” technique in place of dragging if you want to select icons
that are scattered throughout the window. For example, if you want to
select only the icons in the top left and bottom right corner, Shift-
click is the technique to use.
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Shift-click means hold down your keyboard Shift key while you click
on the icons you want to select.

The next illustration shows a situation where Shift-clicking would be
an easier way to select the icons than dragging. Study the illustration
and then try Shift-clicking on your Desktop to select multiple icons:
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To de-select all of the icons you just selected, click in an open area of
the window.

To de-select individual icons, Shift-click on those you want to de-
select. This is a good way to de-select individual icons from a large
group you select with the rubber rectangle.
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Copy an Icon (Drag) GEM Desktop

COPY AN ICON (DRAG)
To copy an icon, drag it where you want it copied and release the
mouse button.

You must begin with the pointer directly on top of the icon you want
to copy; otherwise, you form a rubber rectangle, as described earlier.

Look at the bottom window and find an icon you want to copy. (We’'ll
delete the copy in a later step.) Do not, however, copy a folder icon
for this exercise (if one is present).

Place the pointer on the icon you want to copy and drag it to an open
area in the top window. Notice that when you drag, the pointer
changes from an arrow to a hand. When you release the mouse
button, you see a "dialog” on your screen titled COPY FOLDERS /
ITEMS:

COPY FOLDERS / ITEMS

Folders to copy: __ |
Itens to copy: 1

| oK n} [Cancel |

Place the pointer on the rectangle labeled OK (it's called a “button”)
and click. This starts the copy process.

Copy Multiple Icons

When you use the copy technique just described, the GEM Desktop
copies all currently selected icons. For example, if you select several
icons and then drag any one of them to the copy destination, you end
up with copies of all the selected icons.
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DISPLAY THE GEM DESKTOP MENUS
The GEM Desktop menus contain commands you choose to do things
on the Desktop.

Move the pointer up to the left corner of the Desktop and touch the
word “File”. The File Menu drops down below the menu bar.

Each line in a menu is a command.
Open Some commands are “dimmed” or
Info/Renane ... ¢} “greyed out”, meaning you cannot

choose them because they have no
Belete. .. 3 meaning in the context of what you are
Fornab . .. doing at the time. For example, if no
icons are selected when you display
To Output the File Menu, the Delete command is
Exit to DOS dimmed because the GEM Desktop

doesn’t know what you want to delete.

Slide the pointer along the menu bar. When it touches the other
menu titles, “Options”, "Arrange”, and "“DESKTOP”, their respective
menus drop down.

We're not ready to choose a command yet, so move the pointer to an
open area of the Desktop and click. The last menu you displayed
disappears.
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Delete an Icon GEM Desktop

RENAME AN ICON

In an earlier step, you copied an icon. Now we’ll use one of the menu
commands to change the copy’s name.

1. Select the icon that represents the copy you made earlier by
clicking on it.
2. Display the File Menu again, as you did in the previous step.

3. Drag the pointer up and down through the File Menu. The GEM
Desktop highlights each command (except those that are dimmed)
when the pointer passes over them.

4. When the Info/Rename command is highlighted, click the mouse
button.

5. You see a dialog titled ITEM INFORMATION / RENAME containing
the name of the icon you selected in step 1. The text cursor (a
vertical bar) is at the end of the name.

6. Press Esc to erase the icon name. The text cursor is now at the
beginning of the field.

7. Type JUNK.AAA. The characters appear in the field.
8. Place the pointer on the OK button and click.

You should see an icon labeled JUNK.AAA in your window.

DELETE AN ICON

To delete the icon you copied and renamed in the preceding steps, do
the following:

1. Click on the icon labeled JUNK.AAA to select it.
2. Choose the Delete command from the File Menu.



GEM Desktop Summary

3. When you see the DELETE FOLDERS / ITEMS dialog, click on the
OK button. (If you change your mind and don’t want to delete the
icon, click on the Cancel button.) The GEM Desktop removes the
icon from your window and from your disk.

SUMMARY

This completes the tutorial. You've learned some of the important
Desktop operations and should be able to use the GEM Desktop to do
most of your work.

We recommend that you experiment with the operations you've
learned and then, when you’re ready, read Part 2 to learn about the
GEM Desktop’s advanced operations.

End of Section 3
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SECTION 4

Windows

When you first begin using the GEM Desktop, two windows appear on
your screen. You use the windows to “look inside” things, like a disk
or a folder.

The two windows are identical (although they probably contain
different icons). The following illustration labels the window parts:

Close Box Title Bar Full Box

Scroll Slider —i

Arrows

Scroll Bar




Title Bar GEM Desktop

TITLE BAR

Information in the title bar tells you, at a glance, which disk drive and
folders you have open, if any. The following series of steps explains
what the title bar information means.

Assume the bottom window on your Desktop looks like the one shown
below:

u] Disk Drives:

*

i
FLOPPY DISK HARD DISK

The phrase “Disk Drives” in the title bar tells you the window is

showing you icons representing the disk drives on your computer.

Now assume you place a disk in drive A. When you double~-click on its
icon to open the disk, your window looks like the one shown next:
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GEM Desktop Title Bar

] A:\ .

New Foldar EXPENSES

| »

<

“AN” in the title bar tells you the window is open to disk drive A.

Note the folder icon named EXPENSES in the window above. If you
double-click on this icon, the GEM Desktop displays its contents in the
window, as the next illustration shows:

] A:\EXPENSES\

New Folder FEBRUARY JANUARY MARCH

D [+

4

The information in the title bar has changed and now reads
“A\EXPENSES\", indicating you are in the EXPENSES folder on disk
drive A. In the window, there are now three new folder icons
containing monthly expense information. If you double-click on the
FEBRUARY folder icon, your window looks like the one shown next:
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Close Box GEM Desktop

] A \EXPENSES\FEBRUARY\ .

.

New Folder TRAVEL .EXP PAYROLL.RPT SERVICES.RPT TAXES . WKS

4

The contents of the window and title bar change once again, and so it
goes as you continue opening more folders until you find the specific
icon you want.

CLOSE BOX

Click on the close box to go back to
N the previous folder you opened. If there

is no previous folder, you see disk
drive icons in the window.

If you hold down the mouse button while the pointer is on the close
box, the effect is continuous.
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GEM Desktop Scroll Window Contents

FULL BOX

Your windows can be one of two sizes:
’ normal size or full size. Click on the

full box to change from one size to the
other.

Expanding a window to full size is useful if the disk or folder contains
more icons than the window can show in normal size.

When either window is full size, it covers up the other window.

SCROLL WINDOW CONTENTS

Sometimes a window (even when expanded to full size) won't be able
to display all of the icons the disk or folder contains. When this
happens, use the scroll bar, slider, and the scroll arrows to scroll the
contents through the window to see the other icons. The next
illustration shows the concept of scrolling on the GEM Desktop:
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Scroll Window Contents GEM Desktop
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Scroll Bar and Slider

The scroll bar and slider help you move around in a disk or folder
when it contains more icons than the window can display at one time.
The slider also tells you something about the size of the disk or folder
and your current location within it.

If the slider extends the full length of the &croll bar, the window is
showing you all of the icons in that particular disk or folder. You can't
scroll the window in this case, of course.
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GEM Desktop Scroll Window Contents

If the slider does not extend the full length of the scroll bar, the disk
or folder contains more icons than are currently shown in the window.
Drag the slider up or down the scroll bar to see the other icons.

If you click on the scroll bar, rather than dragging the slider, GEM
Desktop scrolls one full window of icons at a time. Click above the
slider to scroll up and below it to scroll down.

The size of the slider in relation to the scroll bar tells you how much
of the disk or folder is visible in the window. For example, if the slider
extends half the length of the scroll bar, the window is showing you
half the icons in the disk or folder.

The relative position of the slider inside the scroll bar indicates your
position. For example, if the slider is at the bottom of the scroll bar,
you are at the bottom of the disk or folder.

Scroll Arrows

There are two scroll arrows. The one at the top of the scroll bar is
the “up-arrow” and the one at the bottom is the “down-arrow.” Click
on the up-arrow to scroll one line of icons toward the top of the
folder or on the down-arrow to scroll one line toward the bottom.
Hold the mouse button down for continuous scrolling.

Summary of Scroll Techniques

The following illustration summarizes the ways you can use the scroll
bar, slider, and scroll arrows to scroll icons through your windows:



Scroll Window Contents GEM Desktop

Click on up-arrow to
scroll one line of icons
toward top of folder.

Y Click in scroll bar above
< slider to scroll one full
window of icons toward
top of folder.

Drag slider up or down
. to scroll in that direction.
Click in scroll bar below
slider to scroll one full
window of icons toward
bottom of folder.

Click on down-arrow to
scroll one line of icons
toward bottom of folder.
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GEM Desktop Other Window Operations

OTHER WINDOW OPERATIONS

The following window operations are described in detail elsewhere in
this guide.

Display Contents as Text

You can display disk and folder contents as icons or as text. Read the
description of the Show as icons/text command beginning on page
9-11.

Display Contents in a Different Order

Use the commands on the Arrange Menu to arrange the window
contents in various ways. You can arrange the contents by icon name
or type, icon size, or the date the icon was created or last modified.
The Arrange Menu is described beginning on page 9-4.

Save Your Windows ,
If you want your windows and their contents to appear a certain way

each time you start the GEM Desktop, read about the Save desktop
command beginning on page 9-10.

End of Section 4
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SECTION 5

Folders

To be consistent with the desktop metaphor, the GEM Desktop
provides you with folders. You use the folders much the same way
you use them in a file cabinet. That is, you organize your information
into different folders so you can locate it quickly and easily when you
need it.

(If you are experienced with the DOS operating system, it will help you
to know that folders are the same thing as directories and
subdirectories.)

When you first open a disk icon and the disk contains folders, you see
the folders in the window. Until you open one of the folders, you are
in the “root directory” of that disk. A disk does not have to contain
folders, and it can contain icons in the root directory.

CREATE A NEW FOLDER

Folders are represented on the GEM
™ Desktop by an icon like the one shown
here. You can place icons inside
folders, remove them from folders,
open folders to display their contents,
and much more.

The first icon in every window is always a folder named “New Folder”
(except when the window displays disk drive icons). To create a new
folder, double-click on the New Folder icon. You then see the NEW
FOLDER dialog on your screen, as shown next:



Create a New Folder GEM Desktop

NEW FOLDER

Name: I .

| 0K | |Cancel ]

The NEW FOLDER dialog appears so you can give your new folder a
name. (Section 8 explains how to work with dialogs.) Your folder
name can be up to eight characters long and contain an optional
three—character type.

After you name your new folder, its icon appears in the current
window and another New Folder icon replaces the one you just used,
so you always have a new folder available.

Folders Inside Other Folders

Up to a certain point, you can place folders inside other folders. For
example, assume you have a disk containing a folder named
TAXES-86, and you want to create folders named EXPENSES and
INCOME inside the TAXES-86 folder. Here are the steps:

1. With your disk drive icons visible in the window, place the disk
containing the TAXES-86 folder in drive A and double-click on the
disk drive icon to open its window. You see your TAXES-86
folder in the window.

2. Double-click on the TAXES-86 folder. Its contents appear in the
window. You also see a folder labeled New Folder at the top-left
corner of the window.

3. Double~click on the New Folder icon. The NEW FOLDER dialog
appears. Name your new folder EXPENSES.

4. Repeat the previous step, only this time name your new folider
INCOME.

5-2



GEM Desktop Copy a Folder

5. Click on the window’s close box to move back into the TAXES-86
folder. You’'ll see the two new folders, EXPENSES and INCOME, in
your window.

Note: DOS limits the number of folders you can place inside other
folders. The limiting factor is the number of characters in the
combined folder names. When you combine all of the folder names
into one string, the string cannot contain more than 63 characters
(including backslashes). The string can contain a disk drive identifier
(for example “A:“), in which case it can be up to 65 characters long.

COPY A FOLDER

The basic method for copying a folder and its contents is to drag the
folder’s icon to the place where you want the copy created. However,
your results vary depending on several different factors.

If you drag a folder icon to an open area of the same window, you
create a “name conflict” because, in most cases, you cannot have two
folders with the same name. |If you attempt to do this, the GEM
Desktop asks you to enter a different name for the copy you are
making. For details, read “Name Conflicts” in Section 6.

If you drag a folder icon on top of another folder icon and the two
have different names, the GEM Desktop places the first folder icon and
its contents inside the destination folder icon. For example, assume
you have two folders named EXPENSES and PAYROLL. You drag the
PAYROLL folder icon on top of the EXPENSES folder icon and release
the mouse button. ~ If you then open the EXPENSES folder icon, you'll
see the PAYROLL folder icon inside. The original PAYROLL folder icon
still exists and both PAYROLL folders have identical contents.

If you drag a folder icon on top of another folder icon and the two
have the same name, the GEM Desktop copies only the contents of the
first folder into the second. For example, assume you have folders
named EXPENSES on both your hard disk and on a floppy disk. You
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Place an Icon Inside a Folder GEM Desktop

drag your EXPENSES folder icon from the floppy disk on top of your
EXPENSES folder icon on your hard disk and release the mouse button.
If you then open the EXPENSES folder icon on your hard disk, it has its
original contents plus whatever was in the EXPENSES folder icon on
your floppy disk. You will not, however, see a new EXPENSES folder
icon inside of your original EXPENSES folder.

PLACE AN ICON INSIDE A FOLDER

One way to place an icon (document, application program, or existing
folder) inside a folder is to drag the icon on top of the folder’s icon.
When the destination folder icon is highlighted, release the mouse
button.

For example, assume you have an icon named PAYROLL.RPT (Payroll
Report) you want to place inside your EXPENSES folder. With the
EXPENSES folder visible in your window, drag the PAYROLLRPT icon
on top of the folder icon. When the EXPENSES folder icon is
highlighted, release the mouse button.

' Drag icon to .
destination. ‘ E

Another way to place an icon inside a folder is to open the folder and
drag the icon inside the folder’'s window.

Both of these operations place a copy of the icon in the destination
folder; the original icon still exists.
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GEM Desktop

DELETE AN ICON FROM A FOLDER
Follow these steps to delete an icon from a folder:

1. Double-click on the folder’s icon to open its window.
2. Select the icon you want to delete by clicking on it.
3. Choose the Delete command from the File Menu.
To delete multiple icons in a single operation, use the Shift-click or

drag technique to select the icons before you choose the Delete
command.

DELETE A FOLDER
Follow these steps to delete a folder:

1. Select the folder or folders you want to delete.
2. Choose the Delete command from the File Menu.

When you delete a folder, you also delete all of the icons it contains,
including other folders and their contents.
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Rename a Folder GEM Desktop

RENAME A FOLDER
You cannot directly rename a folder, but you can do the following:

1. Create a new folder.
2. Copy the icons from the old folder to the new one.
3. Delete the old folder.

End of Section b
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SECTION 6

Icons

icons are pictorial representations of items you use with the GEM
Desktop. A different style of icon represents each of the following
different types of items:

® Disk drives

® Foliders

® Applications
® Documents

DISK DRIVE ICONS

Disk drive icons (like the ones shown at
R - the left) are labeled with their
| corresponding drive identifier letters: A,

B, C, etc. If the disk drive icons shown
on your Desktop do not exactly match
your computer system, use the Install
disk drive command (page 9-8) to

FLOFPY DISK

C make the necessary additions or
- 00000000 deletions. You can also use this
command to change drive identifier

HARD DISK letters and icon labels.



Appflication and Document Icons GEM Desktop

FOLDER ICONS

=

EXPENSES

Folder icons are labeled with the folder
name you provide when you create the
folder. Folders always appear as the
first icons in a window and are always
in alphabetical order, regardless of how
the other icons in the window are
arranged. The folder’'s name appears in
the window title bar when you open
the folder. For more information about
folders, see Section 5.

APPLICATION AND DOCUMENT ICONS

KA

-

DRAW.AFF

a

Application and document icons are
labeled with their name (up to eight
characters) followed by a type identifier
(up to three characters). The name and
type are separated by a period ().

RARDVARK.GEM

The next figure shows the icon set the GEM Desktop uses to represent
different types of applications and the documents they create. In each
set, the icon on the left represents a type of application, the one on
the right represents the document it creates.
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Note the “Generic” icons in the above figure.
the generic icons to represent an application and its documents unless
you tell it to use a different set of icons. You can use the Configure
application command (described in Section 7) to select a different set
of icons to represent an application and its documents.

|

Generic

The GEM Desktop uses

COPY AN ICON

To copy an icon, do the following:

1. Select the icon you want to copy.

one icon, Shift-click or drag to select the ones you want.

If you want to copy more than

2. Drag the icon or any single icon in a group to the place you want
You can drag to an open area of a window,
directly to a disk icon, or directly to a folder icon.

to store the copies.



Copy an Icon GEM Desktop

3. When the COPY FOLDERS / ITEMS dialog appears, click on the OK
button to start the copy process. (You can bypass the dialog
using the Set preferences command on the Options Menu.)

Name Conflicts

You cannot have two icons with the same name in the same folder or
in the root directory of a disk. If you attempt to do this, the NAME
CONFLICT DURING COPY dialog appears:

NAME CONFLICT DURING COPY

Current name: EM .BAT
Copy’s nane: .

| OK ] |Cancel || Stop |

The three dialog buttons do the following:

OoK Click on this button after you enter a name for
the new copy you are making.

Cancel This button cancels copying of the current
icon. If you're only copying one icon, it

cancels the copy operation. If you're copying
multiple icons, the copy operation continues
with the next icon.

Stop This button stops the entire copy operation no
matter how many icons you are copying.
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GEM Desktop Rename an Icon

DELETE AN ICON

See "Delete an Icon from a Folder” on page 5-5.

RENAME AN ICON

Rename a Disk Drive Icon

Disk drives can have both names and identifying letters. You can use
the Install disk drive command (page 9-8) to change the drive name
and/or identifier letter.

Disk drive names can be anything you want them to be. The GEM
Desktop, by default, names them “Floppy Disk” or “Hard Disk”.

Typically, the letters A and B identify floppy disk drives; the letters C
and D identify hard disks.

Rename a Folder Icon

You cannot directly rename a folder icon. See “Rename a Folder” on
page 5-6 for details.

Rename an Application or Document Icon

To rename an application or document icon, do the following:

1. Select the icon you want to rename.
2. Choose the Info/Rename command from the File Menu.

3. When the ITEM INFORMATION / RENAME dialog appears, press Esc
to erase the icon’s name from the dialog.

4. Enter the name and type you want and then click on OK or press
Enter. (Read “Name Conflicts” earlier in this section for
restrictions on the new name you enter.)
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Rename an Icon GEM Desktop

If you rename either an application or a document that has been
“configured”, you might be breaking the association between the two.
See “Configure an Application” beginning on page 7-6 for details.

End of Section 6
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SECTION 7

Applications

Applications are software programs you run on your computer to
create and process information. This guide classifies applications into
two categories:

® DOS Applications

® GEM Applications

DOS APPLICATIONS

Applications in this category are usually character-based. That is, they
don’t use the basic components typical in the GEM Desktop, such as
drop-down menus, icons, and a mouse pointer. Examples of DOS
applications include the following:

® | otus® 1-2-3®
® MicroPro® WordStar®
® Ashton-Tate® dBase®

With very few exceptions, you can run any DOS application from the
GEM Desktop. Instructions for starting and configuring DOS
applications follow later in this section.



GEM Applications GEM Desktop

GEM APPLICATIONS

Digital Research® and other software development companies publish
GEM applications. These applications use a graphics-based interface,
optional pointing device, drop—~down menus, and other GEM Desktop-
type features.

The following are some GEM applications published by Digital
Research:

GEM Draw™ A graphics program you use to create “object-
based” pictures (circles, lines, rectangles, text,
and so forth).

GEM Paint™ A graphics program you use to create “pixel-
based” pictures. (Pixels are the individual
rectangles of light that form images on your
screen.)

GEM Graph™ A graphics program that translates information
(numbers, statistics, etc.) into pie charts, bar
charts, line graphs, and so forth.

GEM Write™ A word processing program with the ability to
merge graphics—-based pictures with text.

GEM WordChart™ A text-based program you use to create
charts, signs, presentation foils, and overhead
projections. You can subsequently add
graphics to your charts by moving them into
GEM Draw.
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APPLICATION AND DOCUMENT TYPES

Applications and documents all have names. The name appears
beneath the icon when it is displayed in a window. The name can
contain up to eight characters.

Applications and documents also have a type, which follows the name.
The type can contain up to three characters. A period () separates the
name and the type. Here are some examples:

DRAW.APP The name of the icon is DRAW (for GEM Draw)
and its type is APP (indicating a GEM
application).

INCOME.GRF The name of the icon is INCOME and its type

is GRF; this is a graph-type document created
with GEM Graph.

WS.COM The name of the icon is WS (for WordStar)
and its. type is COM (indicating a DOS
application). DOS applications also use type
EXE.

Applications can only be the following types: APP (GEM application),
BAT (batch file), COM, and EXE (DOS applications). You can’t run an
application from the GEM Desktop unless it is one of these types.

Documents can be any type that you or the application program want
them to be.
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START AN APPLICATION

You start DOS and GEM applications the same way, but there are a
variety of ways to start DOS and GEM applications.

Normal Startup

The most common ways to start an application are the following:

® double-click on the application’s icon

® select the application’s icon and then choose the Open command
from the File Menu

If you use either of these methods to start a DOS application, you
‘might see the OPEN APPLICATION dialog, which is explained later in
this section.

Start an Application with a Specific Document

You can start a DOS or GEM application and have it immediately load
a particular document on which you want to work. To start an
application this way, do either of the following:

® double-click on the icon that represents the document you want
loaded

® click on the document’'s icon to select it and then choose the
Open command from the File Menu

Before you can start a GEM or DOS application this way, however, it
must meet the following requirements:
® You must “configure” the application. (This process is described
later in this section.)

® The document must have one of the document types you specify
in the CONFIGURE APPLICATION dialog.

® |f the application is a DOS application, it must be one that lets
you name a document when you start the program.

7-4



GEM Desktop OPEN APPLICATION Dialog

® The application and the document must be in the same folder, or
the application must be in a “search path”. (Search paths are
described later in this section.)

OPEN APPLICATION DIALOG

Some DOS applications let you specify the name of a document you
want to use, or enter parameters that control how the application
operates. If you configure the application as this type {see “Configure
an Application” next in this section), the OPEN APPLICATION dialog
appears when you start the application from the GEM Desktop:

OPEN APPLICATION

Name :
Parameters:

Enter the name of the document you want
to load, or enter parameter values that
are acceptable to this application. | oK | |Cancel |

You can enter a document name or program control parameters in the
Parameters field. (Refer to the application’s manual to find out what
you can enter.)
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CONFIGURE AN APPLICATION

When you configure a DOS or GEM application, you're telling the GEM
Desktop how you want the application to run. You can also choose a
different icon to represent the application and its documents on the
Desktop.

Note: GEM applications published by Digital Research have an
application named INSTALLAPP on the product disk. When you run
this program, it configures the application for you. See your
application manual for complete instructions.

You configure an application by completing the CONFIGURE
APPLICATION dialog, shown in the following illustration:

CONFIGURE APPLICATION

Application nanme: -
Document types: __  _ _ o __

Application type: GEN m | DOS-takes paraneters l
Needs full memory? m

Icon type: Generic

]

| Install | | Remove | [ Cancel |
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Here’s how to configure an application:

1. Click on the application’s icon to select it. The application’s type
must be APP, BAT, COM, or EXE; PAINT.APP, WS.COM, and 123.EXE
are examples. .

If an application is already configured and you want to reconfigure
it, you can either click on one of its document icons or on the
application’s icon.

2. Choose the Configure application command from the Options
Menu and the CONFIGURE APPLICATION dialog appears.

3. In the “Document type” fields, enter the document types you want
to associate with the application. For example, you might want to
associate document types DOC and TXT with documents you
create with your word processing application. You can enter as
many as eight types. Use the Tab key, Shift-Tab keys, or the
mouse pointer to move between fields.

If the application automatically assigns a type to its documents,
enter that type here. For example, Lotus 1-2-3 versions 1 and 1A
produce documents with a WKS' type. Check the application’s
manual to see if it assigns a type to its documents.

If the application doesn’t automatically assign a type, enter one or
more of your own choosing. Be sure you give this type to any
documents you create with the application.

If you associate the same document type with more than one
application, the GEM Desktop recognizes only the last one you
configure.

4. Click on the button following the "Application type” message to
identify the kind of application you're configuring: GEM, DOS, or
“DOS-takes parameters”.

If you're configuring a DOS application that lets you enter a
document name or other parameters when you start the program,
click on the “DOS-takes parameters” button. When you start a
DOS application of this type, the OPEN APPLICATION dialog
appears, as described earlier in this section.
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5. Some applications, such as a spreadsheet program, might require
a lot of memory to operate. If you are configuring an application
of this type, click on the "Yes” button following the message
“Needs full memory?”.

When you click on the Yes button, the GEM Desktop operates in
“step-aside” mode when you start the application. In this mode,
all but the essential parts of the Desktop temporarily leave
memory to make as much room as possible available to the
application. Because this slows down Desktop operations, you
should only indicate that the application "Needs full memory” if
this is truly the case. See your application manual.

6. In the “lcon type” window, you see the application and document
icons the GEM Desktop currently uses to represent these items.
If you don't want to use a different set of icons, skip ahead to
step 7.

The window contains a scroll bar, slider, and scroll arrows, just
like a Desktop window. Scroll the window contents until the
window displays the set of icons you want to use. [f none of the
icons suits you, leave the “Generic” icons in the window.

7. When everything in the CONFIGURE APPLICATION dialog is set the
way you want, click on the Install button. If you want to leave the
dialog without making any changes, click on the Cancel button.

Save an Application’s Configuration

When you configure an application, it remains configured only until
you stop the GEM Desktop unless you use the Save desktop
command to save the configuration. However, the command does
several things at one time, so read the command description on page
9-10 before saving your configuration.

The GEM Desktop limits the number of applications you can configure
to about fifty.

Remove an Application’s Configuration

Removing an application’s configuration breaks the association
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